A1128 N Queens Puzzle (20 point(s))

N皇后--判断对角线上行差值==列差值

1. 原文

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,⋯,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

8q.jpg 9q.jpg
Figure 1 Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K*≤200). Then K lines follow, each gives a configuration in the format “N Q1 Q2 … QN“, where 4≤N≤1000 and it is guaranteed that 1≤QiN* for all i=1,⋯,N. The numbers are separated by spaces.

output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

1
2
3
4
5
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample output:

1
2
3
4
YES
NO
NO
YES

2. 解析

N皇后,放置的皇后每行每列都不重复

判断式 abs(j-i)==abs(num[j]-num[i]) || num[j]-num[i]

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include<cstdio>
#include<algorithm>
using namespace std;
int num[1010]={};
int main()
{
int k;
scanf("%d",&k);
while(k--)
{
int n;
scanf("%d",&n);
int a; int flag=0;
for (int i=0;i<n;i++)
{
scanf("%d",&num[i]);
if (flag==1)
{
continue;
}
for (int j = 0; j < i; ++j)
{
if ((num[j]==num[i])||(abs(j-i)==abs(num[j]-num[i])))
{
flag=1;
break;
}
}
}
if (flag==0)
{
printf("YES\n");
}else{
printf("NO\n");
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1128/
  • 发布时间: 2019-09-03 01:06
  • 更新时间: 2021-10-29 14:09
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!