A1124 Raffle for Weibo Followers (20 point(s))

map充当散列

1. 原文

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

1
2
3
4
5
6
7
8
9
10
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample output 1:

1
2
3
PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

1
2
3
2 3 5
Imgonnawin!
PickMe

Sample output 2:

1
Keep going...

2. 解析

抽奖 第一个为s ,第二个为s+n ,s+2n… 。领过了就s++;

用map记录领奖过的人

1
2
3
if (exist[str]>0){
s++;
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include<iostream>
#include<map>
#include<string>
using namespace std;
map<string,int> exist;
int main()
{
int m,n,s;
cin>>m>>n>>s;
string str; int flag=0;
for (int i = 1; i <= m; ++i)
{
cin>>str;
if (exist[str]>0)
{
s++;
}
if (s==i&&exist[str]==0)
{
flag=1;
cout<<str<<endl;
s+=n;
exist[str]++;
}
}
if (flag==0)
{
cout<<"Keep going..."<<endl;
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1124/
  • 发布时间: 2019-09-03 08:34
  • 更新时间: 2021-10-29 14:09
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!