A1108 Finding Average (20 point(s))

sscanf,sprintf使用

1. 原文

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then Nnumbers are given in the next line, separated by one space.

output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

1
2
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample output 1:

1
2
3
4
5
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

1
2
2
aaa -9999

Sample output 2:

1
2
3
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

2. 解析

输入格式判断

sscanf(c,”%lf”,&num); 字符串以浮点数格式赋值给num

sprintf(c,”%.2f”,num); num以字符串格式赋值给字符串

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include<cstdio>
char c1[1000],c2[1000];
int main()
{
int n;
scanf("%d",&n);
double num=0;
int cnt=0;
double sum=0;
for (int i = 0; i < n; ++i)
{
scanf("%s",c1);
sscanf(c1,"%lf",&num);
sprintf(c2,"%.2f",num);
int flag=0;
for (int i = 0; c1[i] != '\0'; ++i)
{
if (c1[i]!=c2[i])
{
flag=1;
break;
}
}
if (flag==1||(num<-1000||num>1000))
{
printf("ERROR: %s is not a legal number\n",c1);
}else{
cnt++;
sum+=num;
}
}
if (cnt==1)
{
printf("The average of 1 number is %.2f\n",sum);
}else if(cnt>1){
printf("The average of %d numbers is %.2f\n",cnt,sum/cnt);
}else{
printf("The average of 0 numbers is Undefined\n");
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1108/
  • 发布时间: 2019-09-03 12:30
  • 更新时间: 2021-10-29 14:07
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!