A1098 Insertion or Heap Sort (25 point(s))

堆排序,插入排序

1. 原文

原题

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the Nnumbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

1
2
3
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample output 1:

1
2
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

1
2
3
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample output 2:

1
2
Heap Sort
5 4 3 1 0 2 6 7 8 9

2. 解析

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
#include<cstdio>
#include<algorithm>
using namespace std;
int num[110]={};
int temp[110]={};
int match[110]={};
int n;
bool equal(int a[],int b[]){
for (int i = 1; i <= n; ++i)
{
if (a[i]!=b[i])
{
return false;
}
}
return true;
}
bool insertionsort()
{
bool flag=false;
int key=0;
for (int i = 3; i <= n; ++i)
{
sort(num+1,num+i);
if (key>0)
{
flag=true;
printf("Insertion Sort\n");
for (int j = 1; j <= n; ++j)
{
if (j!=1)
{
printf(" ");
}
printf("%d",num[j]);
}
//printf("\n");
break;
}
if (equal(num,match))
{
key++;
}
}
return flag;
}
void adjustdown(int i,int len){
//printf("%d\n",temp[i]);
int j=2*i;
while(j<=len){
if (j+1<=len&&temp[j+1]>temp[j])
{
j++;
}
if (temp[i]>temp[j])
{
break;
}
if (temp[i]<temp[j])
{
swap(temp[i],temp[j]);
i=j;
j=2*i;
}
}
}
void createHeap()
{
for (int i = n/2; i > 0; i--)
{
adjustdown(i,n);
}
}
void heapsort()
{
int key=0;
createHeap();
for (int i = n; i > 1 ; i--)
{
if (key>0)
{
printf("Heap Sort\n");
for (int j = 1; j <= n; ++j)
{
if (j!=1)
{
printf(" ");
}
printf("%d",temp[j]);
}
break;
}
if (equal(temp,match))
{
key++;
}
swap(temp[1],temp[i]);
adjustdown(1,i-1);
}
}
int main()
{
scanf("%d",&n);
for (int i = 1; i <= n; ++i)
{
scanf("%d",&num[i]);
temp[i]=num[i];
}
for (int i = 1; i <= n; ++i)
{
scanf("%d",&match[i]);
}
if(!insertionsort()){
heapsort();
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1098/
  • 发布时间: 2019-09-03 12:31
  • 更新时间: 2021-10-29 14:07
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!