A1092 To Buy or Not to Buy (20 point(s))

第一个子串是否包括第二个子串所有内容,并统计剩余个数

1. 原文

原题

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

1
2
ppRYYGrrYBR2258
YrR8RrY

Sample output 1:

1
Yes 8

Sample Input 2:

1
2
ppRYYGrrYB225
YrR8RrY

Sample output 2:

1
No 2

2. 解析

  • 记录str1 各字符个数exist[c1[i]]++;
  • 遍历str2 当前字符数为0,即为缺少该字符,>0则exist[c2[i]]–;表示已匹配一个

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include<cstdio>
#include<map>
using namespace std;
char c1[1010],c2[1010];
map<char,int> exist;
int main()
{
scanf("%s%s",c1,c2);
int len1=0;
for (int i = 0; c1[i] != '\0'; ++i)
{
len1++;
exist[c1[i]]++;
}
int cnt=0; int len2=0;
for (int i = 0; c2[i]!='\0'; ++i)
{
len2++;
if (exist[c2[i]]==0)
{
cnt++;
}else{
exist[c2[i]]--;
}
}
if (cnt==0)
{
printf("Yes %d\n",len1-len2);
}else{
printf("No %d\n",cnt);
}
return 0;

}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1092/
  • 发布时间: 2019-09-03 12:31
  • 更新时间: 2021-10-29 14:06
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!