A1089 Insert or Merge (25 point(s))

插入排序+归并排序

1. 原文

原题

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, Nintegers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

1
2
3
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample output 1:

1
2
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

1
2
3
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample output 2:

1
2
Merge Sort
1 2 3 8 4 5 7 9 0 6

2. 解析

插入排序 前0至i-1位有序 i插入有序数组中

归并排序 数组分为2段 4段 8段 分别排序 再归并

for使用麻烦,可以用sort直接对段进行排序

1
sort(num,num+i);

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=110;
int num[maxn]={};
int temp[maxn]={};
int match[maxn]={};
int n;
bool equal(int a[],int b[]){
for (int i = 0; i < n; ++i)
{
if (a[i]!=b[i])
{
return false;
}
}
return true;
}
bool insertionsort(){
int key=0;
for (int i = 2; i < n; ++i)
{
sort(num,num+i);
if (key>0)
{
printf("Insertion Sort\n");
for (int j = 0; j < n; ++j)
{
printf("%d",num[j]);
if (j<n-1)
{
printf(" ");
}else{
printf("\n");
}
}
return true;
}
if (equal(num,match))
{
key++;
}

}
return false;
}
void merge(){
int key=0;
for (int step = 2; ; step*=2)
{
for (int i = 0; i < n; i+=step)
{
sort(temp+i,temp+min(i+step,n));
}
if (key>0)
{
printf("Merge Sort\n");
for (int j = 0; j < n; ++j)
{
printf("%d",temp[j]);
if (j<n-1)
{
printf(" ");
}else{
printf("\n");
}
}
break;
}
if (equal(temp,match))
{
key++;
}
if (step>n)
{
break;
}
}
}
int main(){
scanf("%d",&n);
for (int i = 0; i < n; ++i)
{
scanf("%d",&num[i]);
temp[i]=num[i];
}
for (int i = 0; i < n; ++i)
{
scanf("%d",&match[i]);
}
if(!insertionsort()){
merge();
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1089/
  • 发布时间: 2019-09-03 12:31
  • 更新时间: 2021-10-29 14:04
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!