A1083 List Grades (25 point(s))

记录按分数从大到小排序,查找[grade1, grade2]内的记录

1. 原文

原题

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

1
2
3
4
5
6
N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input:

1
2
3
4
5
6
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample output:

1
2
3
Mike CS991301
Mary EE990830
Joe Math990112

Sample Input:

1
2
3
4
2
Jean AA980920 60
Ann CS01 80
90 95

Sample output:

1
NONE

2. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
char name[20],id[20];
int grade;
}stu[100010];
bool cmp(node a,node b){
return a.grade>b.grade;
}
int main(){
int n;
scanf("%d",&n);
for (int i = 0; i < n; ++i)
{
scanf("%s%s%d",stu[i].name,stu[i].id,&stu[i].grade);
}
int min,max;
scanf("%d%d",&min,&max);
sort(stu,stu+n,cmp);
int flag = 0;
for (int i = 0; i < n; ++i)
{
if (stu[i].grade>=min&&stu[i].grade<=max)
{
flag = 1;
printf("%s %s\n",stu[i].name,stu[i].id);
}
}
if (flag == 0)
{
printf("NONE\n");
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1083/
  • 发布时间: 2019-09-03 12:31
  • 更新时间: 2021-10-29 14:04
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!