A1079 Total Sales of Supply Chain (25 point(s))

供应链问题--叶结点有权重

1. 原文

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, K**i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10^10.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample output:

1
42.4

2. 解析

dfs遍历到叶结点,叶结点计算它对应的价格

1
ans+=p*pow((1+r/100),deep)*weight[root];

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
vector<int> v[100010];
int weight[100010]={};
double p,r; double ans=0;
void dfs(int root,int deep){
if (v[root].size()==0)
{
ans+=p*pow((1+r/100),deep)*weight[root];
return;
}
for (int i = 0; i < v[root].size(); ++i)
{
dfs(v[root][i],deep+1);
}

}
int main()
{
int n;
scanf("%d%lf%lf",&n,&p,&r);
for (int i = 0; i < n; ++i)
{
int k;
scanf("%d",&k);
if (k==0)
{
scanf("%d",&weight[i]);
}else{
int a;
for (int j = 0; j < k; ++j)
{
scanf("%d",&a);
v[i].push_back(a);
}
}
}
dfs(0,0);
printf("%.1f\n",ans);
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1079/
  • 发布时间: 2019-09-03 12:32
  • 更新时间: 2021-10-29 14:04
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!