A1074 Reversing Linked List (25 point(s))

反转链表

1. 原文

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

1
Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

1
2
3
4
5
6
7
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample output:

1
2
3
4
5
6
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

2. 解析

链表地址存入vector,地址反转reverse(v.begin()+i,v.begin()+i+k);

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include<cstdio>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<int,int> address,data,nextaddress;
vector<int> v;
int main()
{
int first,n,k;
scanf("%d%d%d",&first,&n,&k);
int a;
for (int i = 0; i < n; ++i)
{
scanf("%d",&a);
address[a]=a;
scanf("%d%d",&data[a],&nextaddress[a]);
}
int cnt=0;
for (int i = first; i != -1; i=nextaddress[i])
{
cnt++;
v.push_back(i);
}
for (int i = 0; i <cnt-cnt%k ; i+=k)
{
reverse(v.begin()+i,v.begin()+i+k);
}
for (int i = 0; i < cnt; ++i)
{
if (i<cnt-1)
{
printf("%05d %d %05d\n",
address[v[i]],data[v[i]],address[v[i+1]]);
}else{
printf("%05d %d -1\n",address[v[i]],data[v[i]]);
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1074/
  • 发布时间: 2019-09-03 12:32
  • 更新时间: 2021-10-29 14:03
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!