A1072 Gas Station (30 point(s))

Dijskstra

1. 原文

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤103), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤104), the number of roads connecting the houses and the gas stations; and D**S, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

1
P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

1
2
3
4
5
6
7
8
9
10
11
12
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample output 1:

1
2
G1
2.0 3.3

Sample Input 2:

1
2
3
2 1 2 10
1 G1 9
2 G1 20

Sample output 2:

1
No Solution

2. 解析

求相对于G1 G2 …的Dijskstra最短路径

求的是dis[i]中相连的最远距离

1
2
3
4
5
if (min>mindis){
minsum=sum;
idx=s;
mindis=min;
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
#include<cstdio>
#include<algorithm>
using namespace std;
const int Inf=312312312;
const int maxn=1100;
int graph[maxn][maxn];
int dis[maxn];
bool visit[maxn]={false};
int n;
int convert(char c[])
{
int idx=0;
if (c[0]=='G')
{
for (int i = 1; c[i] != '\0'; ++i)
{
idx=idx*10+c[i]-'0';
}
idx+=n;
}
else{
for (int i = 0; c[i] != '\0'; ++i)
{
idx=idx*10+c[i]-'0';
}
}
return idx;
}
char c1[10],c2[10];
int main()
{
fill(graph[0],graph[0]+maxn*maxn,Inf);
int m,k,ds;
scanf("%d%d%d%d",&n,&m,&k,&ds);
for (int i = 0; i < k; ++i)
{
scanf("%s%s",c1,c2);
int a=convert(c1);
int b=convert(c2);
scanf("%d",&graph[a][b]);
graph[b][a]=graph[a][b];
}
int minsum=Inf;
int idx=0;
int mindis=-1;
for (int s = n+1; s <= n+m; ++s)
{
fill(dis,dis+maxn,Inf);
fill(visit,visit+maxn,false);
dis[s]=0;
for (int i = 1; i <= n+m; ++i)
{
int u=-1; int min=Inf;
for (int j = 1; j <= n+m; ++j)
{
if (visit[j]==false&&dis[j]<min)
{
u=j;
min=dis[j];
}
}
if (u==-1)
{
break;
}
visit[u]=true;
for (int v = 1; v <= n+m; ++v)
{
if (visit[v]==false&&graph[u][v]!=Inf)
{
if (dis[u]+graph[u][v]<dis[v])
{
dis[v]=dis[u]+graph[u][v];
}
}
}
}
int flag=0; int sum=0; int min=Inf;
for (int i = 1; i <= n; ++i)
{
if (dis[i]>ds)
{
flag=1;
break;
}
if (dis[i]<min)
{
min=dis[i];
}
sum+=dis[i];
}
if (flag==0)
{
if (min>mindis)
{
minsum=sum;
idx=s;
mindis=min;
}else if (min==mindis&&sum<minsum){
minsum=sum;
idx=s;
}
}
}
if (idx==0)
{
printf("No Solution\n");
return 0;
}
printf("G%d\n",idx-n);
printf("%.1f %.1f\n", 1.0*mindis,1.0*minsum/n);
return 0;
}

求的是相连的最远距离as far away as possible

本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1072/
  • 发布时间: 2019-09-03 12:32
  • 更新时间: 2021-10-29 14:03
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!