A1064 Complete Binary Search Tree (30 point(s))

完全二叉树中序转后序

1. 原文

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

1
2
10
1 2 3 4 5 6 7 8 9 0

Sample output:

1
6 3 8 1 5 7 9 0 2 4

2. 解析

二叉查找树的中序一定是有序的

完全二叉树,没有右子树,但有左子树的结点仅有一个

树结构最后两层之前是满二叉树

树第i层 有2^(i-1)个结点,共2^i-1个结点

结点个数为int num=right-left+1;

2^i-1=num, i层数l=log(num+1)/log(2);

叶结点数:n-i层结点数 n-(pow(2,l)-1)

左子树: pow(2,l-1)-1

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int in[1010]={};
int levelorder[1010]={};
void getLevel(int left,int right,int index)
{
if (left>right)
{
return;
}
int num=right-left+1;
int level=log(num+1)/log(2);
int leaves=num-(pow(2,level)-1);
int root=left+(pow(2,level-1)-1)+min((int)pow(2,level-1),leaves);
levelorder[index]=in[root];
getLevel(left,root-1,2*index+1);
getLevel(root+1,right,2*index+2);
}
int main()
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&in[i]);
}
sort(in,in+n);
getLevel(0,n-1,0);
for (int i = 0; i < n; ++i)
{
if (i!=0)
{
printf(" ");
}
printf("%d",levelorder[i]);
}
printf("\n");
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1064/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:03
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!