A1060 Are They Equal (25 point(s))

科学计数法

1. 原文

原题

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×$10^5$ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

1
3 12300 12358.9

Sample output 1:

1
YES 0.123*10^5

Sample Input 2:

1
3 120 128

Sample output 2:

1
NO 0.120*10^3 0.128*10^3

2. 解析

0.000123 123

  • 找.的位置 while(str.length()>0&&str[0]==’0’)

    0后出现说明为小数 e–

    0后不出现说明为整数 e++ 并删除.所在位置str.erase(str.begin()+k);

  • 根据规定位数输出

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
#include<iostream>
#include<string>
using namespace std;
int n;
string getans(string str,int &e){
int k=0;
while(str.length()>0&&str[0]=='0'){
str.erase(str.begin());
}
if (str[0]=='.')
{
str.erase(str.begin());
while(str[0]=='0'&&str.length()>0){
str.erase(str.begin());
e--;
}
}else{
while(k<str.length()&&str[k]!='.'){
k++;
e++;
}
if (str[k]=='.')
{
str.erase(str.begin()+k);
}
}
if (str.length()==0)
{
e=0;
}
k=0; string ans;
int idx=0;
while(idx<n){
if (k<str.length())
{
ans+=str[k++];
}else{
ans+='0';
}
idx++;
}
return ans;

}
int main()
{
cin>>n;
string str1,str2;
cin>>str1>>str2;
int e1=0; int e2=0;
string ans1=getans(str1,e1);
string ans2=getans(str2,e2);
if (ans1==ans2&&e1==e2)
{
cout<<"YES 0."<<ans1<<"*10^"<<e1<<endl;
}else{
cout<<"NO 0."<<ans1<<"*10^"<<e1<<" 0."<<ans2<<"*10^"<<e2<<endl;
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1060/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:02
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!