A1053 Path of Equal Weight (30 point(s))

DFS 取和为s的路径

1. 原文

Given a non-empty tree with root R, and with weight W**i assigned to each tree node T**i. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

img

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

1
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {$A_1$,$A_2$,⋯,$A_n$} is said to be greater than sequence {$B_1$$B_2$,⋯,$B_m$} if there exists 1≤k<min{n,m}such that $A_i$=$B_i$ for *i*=1,⋯,*k*, and $A_{k+1}$>$B_{k+1}$.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample output:

1
2
3
4
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

2. 解析

按权重从高到低排序,return v[a].weight>v[b].weight;

和为s if (sum==s)

记录路径 path[cnt]=idx;

dfs(temp, sum+v[temp].weight,index+1);

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node
{
int weight;
vector<int> children;
}v[110];
bool cmp(int a,int b){
return v[a].weight>v[b].weight;
}
int s;
int path[110]={};
void dfs(int root,int sum,int cnt){
//printf("%d %d\n",root,sum);
if (sum>s)
{
return;
}
if (sum==s)
{
if (v[root].children.size()!=0)
{
return;
}
for (int i = 0; i < cnt; ++i)
{
if (i!=0)
{
printf(" ");
}
printf("%d",v[path[i]].weight);
}
printf("\n");
return;
}
for (int i = 0; i < v[root].children.size(); ++i)
{
int idx=v[root].children[i];
path[cnt]=idx;
dfs(idx,sum+v[idx].weight,cnt+1);
}

}
int main()
{
int n,m;
scanf("%d%d%d",&n,&m,&s);
for (int i = 0; i < n; ++i)
{
scanf("%d",&v[i].weight);
}
int id,k,a;
for (int i = 0; i < m; ++i)
{
scanf("%d%d",&id,&k);
for (int j = 0; j < k; ++j)
{
scanf("%d",&a);
v[id].children.push_back(a);
}
sort(v[id].children.begin(),v[id].children.end(),cmp);
}
path[0]=0;
dfs(0,v[0].weight,1);
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1053/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:02
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!