A1052 Linked List Sorting (25 point(s))

链表数据排序

1. 原文

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<$10^5$) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

1
Address Key Next

where Address is the address of the node in memory, Key is an integer in [−$10^5$,$10^5$], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

1
2
3
4
5
6
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample output:

1
2
3
4
5
6
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

2. 解析

⚠️注意:断链 个数为0 的判断 0 -1

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include<cstdio>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<int,int> address,data,nextaddress;
struct node
{
int address,data;
};
vector<node> v;
bool cmp(node a,node b){
return a.data<b.data;
}
int main()
{
int n,first;
scanf("%d%d",&n,&first);
int a;
for (int i = 0; i < n; ++i)
{
scanf("%d",&a);
address[a]=a;
scanf("%d%d",&data[a],&nextaddress[a]);
}
for (int i = first; i !=-1 ; i=nextaddress[i])
{
node temp;
temp.address=i;
temp.data=data[i];
v.push_back(temp);
}
if((int)v.size()==0){
printf("0 -1");
return 0;
}
sort(v.begin(),v.end(),cmp);
printf("%lu %05d\n", v.size(),v[0].address);
for (int i = 0; i < v.size(); ++i)
{
if (i<v.size()-1)
{
printf("%05d %d %05d\n", v[i].address,v[i].data,v[i+1].address);
}else{
printf("%05d %d -1\n", v[i].address,v[i].data);
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1052/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:02
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!