A1051 Pop Sequence (25 point(s))

栈顺序已知,得不同出栈顺序,栈空间有限

1. 原文

原题

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

1
2
3
4
5
6
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample output:

1
2
3
4
5
YES
NO
NO
YES
NO

2. 解析

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include<cstdio>
#include<stack>
using namespace std;
int num[1010]={};
int main()
{
int m,n,k;
scanf("%d%d%d",&m,&n,&k);
while(k--)
{
for (int i = 1; i <= n; ++i)
{
scanf("%d",&num[i]);
}
int current=1;
stack<int> s;
for (int i = 1; i <= n; ++i)
{
s.push(i);
if (s.size()>m)
{
break;
}
while(!s.empty()&&s.top()==num[current]){
s.pop();
current++;
}
}
if (current==n+1)
{
printf("YES\n");
}else{
printf("NO\n");
}


}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1051/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:02
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!