A1050 String Subtraction (20 point(s))

比对字符串

1. 原文

原题

Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than $10^4$. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

output Specification:

For each test case, print S1−S2 in one line.

Sample Input:

1
2
They are students.
aeiou

Sample output:

1
Thy r stdnts.

2. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<iostream>
#include<map>
#include<string>
using namespace std;

map<char,int> match;
int main()
{
string str1,str2;
getline(cin,str1);
getline(cin,str2);
for (int i = 0; str2[i] != '\0'; ++i)
{
match[str2[i]]++;
}
for (int i = 0; str1[i] != '\0'; ++i)
{
if (match[str1[i]]==0)
{
cout<<str1[i];
}
}
return 0;
}

3. AC代码2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<iostream>
#include<string>
using namespace std;
int main()
{
string str1,str2;
getline(cin,str1);
getline(cin,str2);
for (int i = 0; str1[i] != '\0'; ++i)
{
if (str2.find(str1[i])==string::npos)
{
cout<<str1[i];
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1050/
  • 发布时间: 2019-09-03 12:33
  • 更新时间: 2021-10-29 14:01
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!