A1044 Shopping in Mars (25 point(s))

相加和为m的连续序列

1. 原文

原题

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤$10^5$), the total number of diamonds on the chain, and M (≤$10^8$), the amount that the customer has to pay. Then the next line contains N positive numbers $D_1$⋯$D_N$ ($D_i$≤$10^3$ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

output Specification:

For each test case, print i-j in a line for each pair of ij such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + … + Dj >M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

1
2
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample output 1:

1
2
3
4
1-5
4-6
7-8
11-11

Sample Input 2:

1
2
5 13
2 4 5 7 9

Sample output 2:

1
2
2-4
4-5

2. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
#include<cstdio>
int num[100010]={};
int ans[100010]={};
int n,m;
void getSum(int i,int &j,int &sum){
int left = i;
int right = n;
while(left<right){
int mid = (left+right)/2;
if (num[mid]-num[i-1]>=m)
{
right = mid;
}else{
left = mid + 1;
}
}
sum = num[right]-num[i-1];
j = right;
}
int main(){
scanf("%d%d",&n,&m);
int max = 0;
for (int i = 1; i <= n; ++i)
{
int a;
scanf("%d",&a);
max+=a;
num[i]=num[i-1]+a;
}
int idx = 0;
for (int i = 1; i <= n; ++i)
{
int j,sum;
getSum(i,j,sum);
if (sum>max)
{
continue;
}
else if(sum>=m){
if (sum<max)
{
max=sum;
idx=0;
}
ans[idx++]=i;
ans[idx++]=j;
}
}
for (int i = 0; i < idx; i+=2)
{
printf("%d-%d\n",ans[i],ans[i+1]);
}



return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1044/
  • 发布时间: 2019-09-03 12:34
  • 更新时间: 2021-10-29 14:00
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!