A1039 Course List for Student (25 point(s))

姓名匹配课号,课号排序

1. 原文

原题

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students $N_i$ (≤200) are given in a line. Then in the next line, $N_i$ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample output:

1
2
3
4
5
6
7
8
9
10
11
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

2. 解析

字母转数字

1
2
3
4
5
6
7
8
9
int convert(char c[]){
int idx=0;
for (int i = 0; i < 3; ++i)
{
idx=idx*26+c[i]-'A';
}
idx=idx*10+c[3]-'0';
return idx;
}

最后一个测试点,段错误,maxn = 400010; map会超时

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=26*26*26*10;
int convert(char c[]){
int idx=0;
for (int i = 0; i < 3; ++i)
{
idx=idx*26+c[i]-'A';
}
idx=idx*10+c[3]-'0';
return idx;
}
char str[5];
vector<int> v[maxn];
int main()
{
int n,k;
scanf("%d%d",&n,&k);
for (int i = 0; i < k; ++i)
{
int coursei,cnt;
scanf("%d%d",&coursei,&cnt);
for (int j = 0; j < cnt; ++j)
{
scanf("%s",str);
int a=convert(str);
v[a].push_back(coursei);
}
}
for (int i = 0; i < n; ++i)
{
scanf("%s",str);
int a=convert(str);
sort(v[a].begin(),v[a].end());
printf("%s %lu",str,v[a].size());
for (int j = 0; j < v[a].size(); ++j)
{
printf(" %d",v[a][j]);
}
printf("\n");
}
return 0;
}

使用map超时

本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1039/
  • 发布时间: 2019-09-03 12:34
  • 更新时间: 2021-10-29 14:00
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!