A1038 Recover the Smallest Number (30 point(s))

组成最小数

1. 原文

原题

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤$10^4$) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

1
5 32 321 3214 0229 87

Sample output:

1
22932132143287

2. 解析

组最小数

1
2
3
4
bool cmp(string a,string b)
{
return a+b<b+a;
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string str[10010];
bool cmp(string a,string b){
return a+b<b+a;
}
int main(){
int n;
cin>>n;
for (int i = 0; i < n; ++i)
{
cin>>str[i];
}
sort(str,str+n,cmp);
string ans;
for (int i = 0; i < n; ++i)
{
ans+=str[i];
}
while(ans.length()-1>0&&ans[0]=='0'){
ans.erase(ans.begin());
}
cout<<ans<<endl;
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1038/
  • 发布时间: 2019-09-03 12:34
  • 更新时间: 2021-10-29 14:00
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!