A1037 Magic Coupon (25 point(s))

排序后取两数组相乘>0的值

1. 原文

原题

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N‘s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M 7) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M 7) to get M 28 back; coupon 2 to product 2 to get M​ 12 back; and coupon 4 to product 4 to get M​ 3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons $N_C$, followed by a line with $N_C$ coupon integers. Then the next line contains the number of products $N_P$, followed by a line with $N_P$ product values. Here 1≤$N_C$,$N_P$≤$10^5$, and it is guaranteed that all the numbers will not exceed $2^{30}$.

output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

1
2
3
4
4
1 2 4 -1
4
7 6 -2 -3

Sample output:

1
43

2. 解析

两数组一对一相乘,最大乘积和

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<cstdio>
#include<algorithm>
using namespace std;
int coupon[100010]={};
int product[100010]={};
int main()
{
int nc;
scanf("%d",&nc);
for (int i = 0; i < nc; ++i)
{
scanf("%d",&coupon[i]);
}
int np;
scanf("%d",&np);
for (int i = 0; i < np; ++i)
{
scanf("%d",&product[i]);
}
sort(coupon,coupon+nc);
sort(product,product+np);
int i=0;int j=0;
int ans=0;
while(i<nc&&j<np&&coupon[i]<0&&product[j]<0){
ans+=coupon[i]*product[j];
i++;
j++;
}
i=nc-1; j=np-1;
while(i>=0&&j>=0&&coupon[i]>0&&product[j]>0){
ans+=coupon[i]*product[j];
i--;
j--;
}
printf("%d\n",ans);
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1037/
  • 发布时间: 2019-09-03 12:34
  • 更新时间: 2021-10-29 14:00
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!