A1036 Boys vs Girls (25 point(s))

女生取最高分数,男生取最低分数,差值

1. 原文

原题

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference $grade_F$−$grade_M$. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

1
2
3
4
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample output 1:

1
2
3
Mary EE990830
Joe Math990112
6

Sample Input 2:

1
2
1
Jean M AA980920 60

Sample output 2:

1
2
3
Absent
Jean AA980920
NA

2. 解析

女生最高分,男生最低分,当某一方不存在时,输出Absent

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include<cstdio>
const int Inf = 1<<30;
struct node{
char name[20],id[20],gender[5];
int grade;
};
int main(){
node female,male;
female.grade = -1;
male.grade = Inf;
int n;
scanf("%d",&n);
for (int i = 0; i < n; ++i)
{
node temp;
scanf("%s%s%s%d",temp.name,temp.gender,temp.id,&temp.grade);
if (temp.gender[0]=='F')
{
if (temp.grade>female.grade)
{
female = temp;
}
}else{
if (temp.grade<male.grade)
{
male = temp;
}
}
}
if (female.grade==-1)
{
printf("Absent\n");
}else{
printf("%s %s\n",female.name,female.id);
}
if (male.grade==Inf)
{
printf("Absent\n");

}else{
printf("%s %s\n", male.name,male.id);
}
if (female.grade!=-1&&male.grade!=Inf)
{
printf("%d\n", female.grade-male.grade);
}else{
printf("NA\n");
}


return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1036/
  • 发布时间: 2019-09-03 12:34
  • 更新时间: 2021-10-29 14:00
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!