A1028 List Sorting (25 point(s)

不同部分排序

1. 原文

原题

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤$10^5$) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

1
2
3
4
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample output 1:

1
2
3
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

1
2
3
4
5
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample output 2:

1
2
3
4
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

1
2
3
4
5
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample output 3:

1
2
3
4
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

2. 解析

排序

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int id,grade;
char name[10];
}v[100010];
int c;
bool cmp(node a,node b)
{
if (c==1)
{
return a.id<b.id;
}else if(c==2){
if (strcmp(a.name,b.name)!=0)
{
return strcmp(a.name,b.name)<0;
}else{
return a.id<b.id;
}
}else{
if (a.grade!=b.grade)
{
return a.grade<b.grade;
}else{
return a.id<b.id;
}
}
}
int main()
{
int n;
scanf("%d%d",&n,&c);
node temp;
for (int i = 0; i < n; ++i)
{
scanf("%d%s%d",&temp.id,temp.name,&temp.grade);
v[i]=temp;
}
sort(v,v+n,cmp);
for (int i = 0; i < n; ++i)
{
printf("%06d %s %d\n",v[i].id,v[i].name,v[i].grade);
}

return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1028/
  • 发布时间: 2019-09-03 12:35
  • 更新时间: 2021-10-29 13:59
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!