A1019 General Palindromic Number (20 point(s))

D进制下的数是否是回文

1. 原文

原题

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits $a_i$ as $∑_{i=0}^k$($a_i$$b_i$). Here, as usual, 0≤$a_i$<b for all i and $a_k$ is non-zero. Then N is palindromic if and only if $a_i$=$a_{k−i}$ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤$10^9$ is the decimal number and 2≤b≤$10^9$ is the base. The numbers are separated by a space.

output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print Nas the number in base b in the form “$a_k$ $a_{k−1}$ … $a_0$”. Notice that there must be no extra space at the end of output.

Sample Input 1:

1
27 2

Sample output 1:

1
2
Yes
1 1 0 1 1

Sample Input 2:

1
121 5

Sample output 2:

1
2
No
4 4 1

2. 解析

回文判断

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<cstdio>
int num[20]={};
int main(){
int n,b;
scanf("%d%d",&n,&b);
int index = 0;
do{
num[index++]=n%b;
n/=b;
}while(n!=0);
bool flag = 0;
for (int i = 0; i < index/2; ++i)
{
if (num[i]!=num[index-1-i])
{
flag = 1;
printf("No\n");
break;
}
}
if (flag==0)
{
printf("Yes\n");
}
for (int i = index-1; i >= 0; i--)
{
printf("%d",num[i]);
if (i>0)
{
printf(" ");
}else{
printf("\n");
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1019/
  • 发布时间: 2019-09-03 12:35
  • 更新时间: 2021-10-29 13:59
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!