A1012 The Best Rank (25 point(s))

排序

1. 原文

原题

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

1
2
3
4
5
StudentID  C  M  E  A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample output:

1
2
3
4
5
6
1 C
1 M
1 E
1 A
3 A
N/A

2. 解析

按每科成绩排序,取最好的名次和科目索引

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
int id,best,index;
int course[4],rank[4];
node(){
index=best=0;
}
}stu[2010];
int flag;
bool cmp(node a,node b){
return a.course[flag]>b.course[flag];
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
node temp;
for (int i = 0; i < n; ++i)
{
scanf("%d",&temp.id);
int sum=0;
for (int j = 1; j <= 3; ++j)
{
scanf("%d",&temp.course[j]);
sum+=temp.course[j];
}
temp.course[0]=(1.0)*sum/3+0.5;
stu[i]=temp;
}
for (flag = 0; flag < 4; ++flag)
{
sort(stu,stu+n,cmp);
stu[0].rank[flag]=1;
for (int i = 1; i < n; ++i)
{
stu[i].rank[flag]=stu[i-1].rank[flag];
if (stu[i].course[flag]!=stu[i-1].course[flag])
{
stu[i].rank[flag]=i+1;
}
}
}
for (int i = 0; i < n; ++i)
{
int best=stu[i].rank[0];
for (int j = 1; j < 4; ++j)
{
if (stu[i].rank[j]<best)
{
best=stu[i].rank[j];
stu[i].index=j;
}
}
stu[i].best=best;
}
int a;
char c[]={"ACME"};
for (int i = 0; i < m; ++i)
{
scanf("%d",&a);
int flag=0;
for (int j = 0; j < n; ++j)
{
if (stu[j].id==a)
{
flag=1;
printf("%d %c\n",stu[j].best,c[stu[j].index]);
break;
}
}
if (flag==0)
{
printf("N/A\n");
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1012/
  • 发布时间: 2019-09-03 12:36
  • 更新时间: 2021-10-29 13:59
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!