A1009 Product of Polynomials (25 point(s))

多项式相乘

1. 原文

原题

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K $N_1$ $a_{N1}$ $N_2$ $a_{N2}$ … $N_K$ $a_{NK}$

where K is the number of nonzero terms in the polynomial, $N_i$ and $a_{Ni}$ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤$N_K$<⋯<$N_2$<$N_1$≤1000.

output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

1
2
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample output:

1
3 3 3.6 2 6.0 1 1.6

2. 解析

两个多项式相乘,多项式的每一项都需要乘以另一个多项式的每一项,指数相加,系数相乘。

指数相加,系数相乘

ans[a+i]+=b*num[i];

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<cstdio>
const int maxn = 1010;
double num[maxn]={};
double ans[2*maxn]={};
int main(){
int k;
scanf("%d",&k);
int a;
double b;
for (int i = 0; i < k; ++i)
{
scanf("%d%lf",&a,&b);
num[a]+=b;
}
scanf("%d",&k);
while(k--)
{
scanf("%d%lf",&a,&b);
for (int i = 0; i < maxn; ++i)
{
if (num[i]!=0)
{
ans[a+i]+=num[i]*b;
}
}
}
int cnt = 0;
for (int i = 0; i < 2*maxn; ++i)
{
if (ans[i]!=0)
{
cnt++;
}
}
printf("%d",cnt);
for (int i = 2*maxn-1; i >= 0; i--)
{
if (ans[i]!=0)
{
printf(" %d %.1f",i,ans[i]);
}
}
printf("\n");

return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1009/
  • 发布时间: 2019-09-03 12:36
  • 更新时间: 2021-10-29 13:58
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!