A1004 Counting Leaves (30 point(s))

每层叶结点数

1. 原文

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

1
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

1
2
2 1
01 1 02

Sample output:

1
0 1

2. 解析

从叶节点开始dfs遍历,遇到叶节点时,更新当前叶所在层的叶节点数 level[deep]++;

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include<cstdio>
#include<vector>
using namespace std;
vector<int> v[110];
vector<int> level[110];
int maxdeep=-1;
void dfs(int root,int deep)
{
if (deep>maxdeep)
{
maxdeep=deep;
}
if (v[root].size()==0)
{
level[deep].push_back(root);
return;
}
for (int i = 0; i < v[root].size(); ++i)
{
dfs(v[root][i],deep+1);
}
}
int main()
{
int n,m,k,id,kid;
scanf("%d%d",&n,&m);
while(m--)
{
scanf("%d%d",&id,&k);
for (int i = 0; i < k; ++i)
{
scanf("%d",&kid);
v[id].push_back(kid);
}
}
dfs(1,0);
int key=0;
for (int i = 0; i <= maxdeep; ++i)
{
if (key>0)
{
printf(" ");
}else{
key++;
}
printf("%d",(int)level[i].size());
}
printf("\n");
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1004/
  • 发布时间: 2019-09-03 12:36
  • 更新时间: 2021-10-29 13:58
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!