A1003 Emergency (25 point(s))

Dijskstra

1. 原文

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

1
2
3
4
5
6
7
8
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample output:

1
2 4

2. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=510;
const int Inf=312312312;
int graph[maxn][maxn];
int weight[510]={};
int dis[maxn];
bool visit[maxn]={false};
int num[maxn]={};
int w[maxn]={};
int main()
{
fill(graph[0],graph[0]+maxn*maxn,Inf);
int n,m,c1,c2;
scanf("%d%d%d%d",&n,&m,&c1,&c2);
for (int i = 0; i < n; ++i)
{
scanf("%d",&weight[i]);
}
int a,b;
for (int i = 0; i < m; ++i)
{
scanf("%d%d",&a,&b);
scanf("%d",&graph[a][b]);
graph[b][a]=graph[a][b];
}
fill(dis,dis+maxn,Inf);
dis[c1]=0;
w[c1]=weight[c1];
num[c1]=1;
for (int i = 0; i < n; ++i)
{
int u=-1; int min=Inf;
for (int j = 0; j < n; ++j)
{
if (visit[j]==false&&min>dis[j])
{
u=j;
min=dis[j];
}
}
if (u==-1)
{
break;
}
visit[u]=true;
for (int v = 0; v < n; ++v)
{
if (visit[v]==false&&graph[u][v]!=Inf)
{
if (dis[u]+graph[u][v]<dis[v])
{
dis[v]=dis[u]+graph[u][v];
w[v]=w[u]+weight[v];
num[v]=num[u];
}else if(dis[v]==dis[u]+graph[u][v]){
if (w[v]<w[u]+weight[v])
{
w[v]=w[u]+weight[v];
}
num[v]+=num[u];
}
}
}
}
printf("%d %d\n",num[c2],w[c2]);
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/03/A1003/
  • 发布时间: 2019-09-03 12:36
  • 更新时间: 2021-10-29 13:58
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!