A1146 Topological Order (25 point(s))

拓扑排序

1. 原文

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample output:

1
3 4

2. 解析

拓扑排序:

输出入度为0的结点,删除以该结点为起点的边,输出现在入度为0的结点,continue…

建立vector记录结点边信息,记录终点indegree[]++入度数

遍历记录查询的点 当indegree[i]>0 说明不能组成一组拓扑排序

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#include<cstdio>
#include<vector>
using namespace std;
const int maxn=1010;
vector<int> v[maxn];
int indegree[maxn]={};
int temp[maxn]={};
vector<int> ans;
int main()
{
int n,m;
scanf("%d%d",&n,&m);
int a,b;
for (int i = 0; i < m; ++i)
{
scanf("%d%d",&a,&b);
v[a].push_back(b);
indegree[b]++;
temp[b]++;
}
int k; int key=0;
scanf("%d",&k);
for(int t=0;t<k;t++){
int flag=0;
for (int i = 0; i < n; ++i)
{
scanf("%d",&a);
if (indegree[a]!=0)
{
flag=1;
continue;
}else{
for (int j = 0; j < v[a].size(); ++j)
{
indegree[v[a][j]]--;
}
}
}
if (flag==1)
{
if (key==0)
{
printf("%d",t);
key++;
}else{
printf(" %d",t);
}
}
for (int i = 1; i <= n; ++i)
{
indegree[i]=temp[i];
}
}
printf("\n");
return 0;
}

indegree数组需要在本次查询后重新赋值为原始状态

本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1146/
  • 发布时间: 2019-09-02 14:33
  • 更新时间: 2021-10-29 14:11
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!