A1143 Lowest Common Ancestor (30 point(s))

二叉查找树的共同祖先

1. 原文

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

1
2
3
4
5
6
7
8
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample output:

1
2
3
4
5
6
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

2. 解析

不同于A1155 该树是二叉查找树 左< 根< 右 先序先输出的必是根

直接比较根的值,当u,v 值在根两侧时即为答案

1
2
3
4
5
6
for (int i = 0; i < n; ++i){
a=pre[i];
if ((u<=a&&v>=a)||(u>=a&&v<=a)){
break;
}
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<cstdio>
#include<map>
using namespace std;
map<int,int> exist;
int pre[10010]={};
int main(){
int m,n;
scanf("%d%d",&m,&n);
for (int i = 0; i < n; ++i)
{
scanf("%d",&pre[i]);
exist[pre[i]]++;
}
int u,v;
while(m--)
{
scanf("%d%d",&u,&v);
int a=0;
for (int i = 0; i < n; ++i)
{
a=pre[i];
if ((u<=a&&v>=a)||(u>=a&&v<=a))
{
break;
}
}
if (exist[u]==0&&exist[v]==0)
{
printf("ERROR: %d and %d are not found.\n",u,v);
}else if(exist[u]==0){
printf("ERROR: %d is not found.\n",u);
}else if(exist[v]==0){
printf("ERROR: %d is not found.\n",v);
}else if(u==a){
printf("%d is an ancestor of %d.\n",u,v);
}else if(v==a){
printf("%d is an ancestor of %d.\n",v,u);
}else{
printf("LCA of %d and %d is %d.\n",u,v,a);
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1143/
  • 发布时间: 2019-09-02 15:40
  • 更新时间: 2021-10-29 14:10
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!