A1141 PAT Ranking of Institutions (25 point(s))

学校名称转小写,统计学号相同者的个数和总分

1. 原文

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

1
ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, Athe advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

1
Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample output:

1
2
3
4
5
6
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

2. 解析

利用结构体统计信息 struct node{ };

字母转换 #include< cctype> tolower(char)

排序 sort(); bool cmp(node a,node b){}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include<cstdio>
#include<algorithm>
#include<cctype>
#include<cstring>
#include<string>
#include<map>
#include<vector>
using namespace std;
struct node
{
string school;
int cnt,tws;
};
bool cmp(node a,node b)
{
if (a.tws!=b.tws)
{
return a.tws>b.tws;
}else if (a.cnt!=b.cnt)
{
return a.cnt<b.cnt;
}else{
return a.school<b.school;
}
}
char id[7],school[7];
map<string,int> cnt;
map<string,double> score;
vector<node> v;
int main()
{
int n;
scanf("%d",&n);
int grade;
for (int i = 0; i < n; ++i)
{
scanf("%s%d%s",id,&grade,school);
string str;
for (int i = 0; i < strlen(school); ++i)
{
str+=tolower(school[i]);
}
cnt[str]++;
if (id[0]=='A'){ score[str]+=grade; }
if (id[0]=='B'){ score[str]+=grade/1.5; }
if (id[0]=='T'){ score[str]+=grade*1.5; }
}
for(map<string,int>::iterator i=cnt.begin();i!=cnt.end();i++)
{
node temp;
temp.school=i->first;
temp.cnt=i->second;
temp.tws=score[i->first];
v.push_back(temp);
}
sort(v.begin(), v.end(),cmp);
printf("%lu\n", v.size());
int r=1;
for (int i = 0; i < v.size(); ++i)
{
if (i>0&&v[i].tws!=v[i-1].tws)
{
r=i+1;
}
printf("%d %s %d %d\n",r,v[i].school.c_str(),v[i].tws,v[i].cnt);
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1141/
  • 发布时间: 2019-09-02 16:54
  • 更新时间: 2021-10-29 14:10
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!