A1140 Look-and-say Sequence (20 point(s))

递推字符串

1. 原文

Look-and-say sequence is a sequence of integers as the following:

1
D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D(corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1
1 8

Sample output:

1
1123123111

2. 解析

字符串string – STL

比较字符串记录重复值cnt++,当字符不相等时记录当前字符和cnt

1
2
3
4
5
6
7
if (str[j]==str[j+1]){
cnt++;
}else{
ans+=str[j];
ans+=cnt+'0';
cnt=1;
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include<iostream>
#include<string>
using namespace std;
int main()
{
int d,n;
scanf("%d%d",&d,&n);
string str;
if (n==1)
{
printf("%d",d);
return 0;
}
str=d+'0';
for (int i = 0; i < n-1; ++i)
{
int cnt=1; string ans;
for (int j=0;j<str.length();j++)
{
if (str[j]==str[j+1])
{
cnt++;
}else{
ans+=str[j];
ans+=cnt+'0';
cnt=1;
}
}
str=ans;
}
printf("%s\n",str.c_str());

return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1140/
  • 发布时间: 2019-09-02 17:19
  • 更新时间: 2021-10-29 14:10
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!