A1136 A Delayed Palindrome (20 point(s))

1000位的数用int,long已经不能承载,用字符串string/char[1000]

1. 原文

Consider a positive integer N written in standard notation with k+1 digits ai as aka1a0 with 0≤ai<10 for all i* and ak>0. Then N is palindromic if and only if ai=aki* for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

1
A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

1
97152

Sample output 1:

1
2
3
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

1
196

Sample output 2:

1
2
3
4
5
6
7
8
9
10
11
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

2. 解析

反转字符串reverse() 在algorithm中

大整数之间的计算

1
2
3
4
5
6
7
8
9
10
11
12
 string temp;
int carry=0;
for (int i = str.length()-1; i >= 0 ; i--)
{
int sum=(str[i]-'0')+(ans[i]-'0')+carry;
temp+=sum%10+'0';
carry=sum/10;
}
if (carry>0)
{
temp+=carry+'0';
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
string str,ans;
cin>>str;
int cnt=0;
while(cnt<10){
ans=str;
reverse(str.begin(),str.end());
if (ans==str)
{
cout<<ans<<" is a palindromic number."<<endl;
return 0;
}
string temp;
int carry=0;
for (int i = str.length()-1; i >= 0 ; i--)
{
int sum=(str[i]-'0')+(ans[i]-'0')+carry;
temp+=sum%10+'0';
carry=sum/10;
}
if (carry>0)
{
temp+=carry+'0';
}
reverse(temp.begin(),temp.end());
cout<<ans<<" + "<<str<<" = "<<temp<<endl;
str=temp;
cnt++;
}
if (cnt==10)
{
cout<<"Not found in 10 iterations."<<endl;
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1136/
  • 发布时间: 2019-09-02 21:12
  • 更新时间: 2021-10-29 14:10
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!