A1133 Splitting A Linked List (25 point(s))

链表静态表示address[a]=a; data[a];nextaddress[a]

1. 原文

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

1
Address Data Next

where Address is the position of the node, Data is an integer in [−105,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

1
2
3
4
5
6
7
8
9
10
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample output:

1
2
3
4
5
6
7
8
9
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

2. 解析

链表各部分用map<int,int> 表示 address,data,nextaddress.

链表存在断链情况,for(int i=first;i!=-1;i=nextaddress[i]) 保证链

存入结果

1
2
3
4
5
6
7
for (int i = first; i != -1; i=nextAddress[i])
{
if (data[i]<0)
{
v.push_back(i);
}
}

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include<cstdio>
#include<map>
#include<vector>
using namespace std;
map<int,int> address,data,nextAddress;
vector<int> v;
int main()
{
int first,n,k;
scanf("%d%d%d",&first,&n,&k);
int a;
for (int i = 0; i < n; ++i)
{
scanf("%d",&a);
address[a]=a;
scanf("%d%d",&data[a],&nextAddress[a]);
}
for (int i = first; i != -1; i=nextAddress[i])
{
if (data[i]<0)
{
v.push_back(i);
}
}
for (int i = first; i != -1; i=nextAddress[i])
{
if (data[i]>=0&&data[i]<=k)
{
v.push_back(i);
}
}
for (int i = first; i != -1; i=nextAddress[i])
{
if (data[i]>k)
{
v.push_back(i);
}
}
for (int i = 0; i < v.size(); ++i)
{
if (i<v.size()-1)
{
printf("%05d %d %05d\n",address[v[i]],data[v[i]],address[v[i+1]]);
}else{
printf("%05d %d -1\n",address[v[i]],data[v[i]]);
}
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/09/02/A1133/
  • 发布时间: 2019-09-02 22:18
  • 更新时间: 2021-10-29 14:10
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!