A1155 Heap Paths (30 point(s))

二叉查找树的共同祖先

1. 原文

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

1
2
8
98 72 86 60 65 12 23 50

Sample Output 1:

1
2
3
4
5
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

1
2
8
8 38 25 58 52 82 70 60

Sample Output 2:

1
2
3
4
5
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

1
2
8
10 28 15 12 34 9 8 56

Sample Output 3:

1
2
3
4
5
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

2. 解析思路

遍历:根右左遍历

堆判断: 大根堆 i > 2i && i> 2i +1 , 小根堆 i < 2i && i< 2i +1

遍历方式直接可用递归实现

3. AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#include<cstdio>
#include<vector>
using namespace std;
const int maxn=1010;
int level[maxn]={};
vector<int> v;
int n;
void dfs(int root)
{
if (2*root>n&&2*root+1>n)
{
if (root<=n)
{
for (int i = 0; i < v.size(); ++i)
{
if (i!=0)
{
printf(" ");
}
printf("%d",level[v[i]]);
}
printf("\n");
}
}
else{
v.push_back(2*root+1);
dfs(2*root+1);
v.pop_back();
v.push_back(2*root);
dfs(2*root);
v.pop_back();
}
}
int main()
{
scanf("%d",&n);
for (int i = 1; i <= n; ++i)
{
scanf("%d",&level[i]);
}
v.push_back(1);
dfs(1);
bool max=true; bool min=true;
for (int i = 1; i < n/2; ++i)
{
if(level[i]<level[2*i]||level[i]<level[2*i+1])
{
max=false;
}
if(level[i]>level[2*i]||level[i]>level[2*i+1])
{
min=false;
}
}
if (max)
{
printf("Max Heap\n");
}else if (min)
{
printf("Min Heap\n");
}
else{
printf("Not Heap\n");
}
return 0;
}
本文结束  感谢您的阅读
  • 本文作者: Wang Ting
  • 本文链接: /zh-CN/2019/08/30/A1155/
  • 发布时间: 2019-08-30 09:47
  • 更新时间: 2021-10-29 14:11
  • 版权声明: 本博客所有文章除特别声明外,均采用 BY-NC-SA 许可协议。转载请注明出处!